Перейти к содержимому


Фото
- - - - -

Установка DrWeb ESS 11 в среде МСВС 5.0

Рекомендации

  • Please log in to reply
28 ответов в этой теме

#1 Jbanchic

Jbanchic

    Newbie

  • Posters
  • 64 Сообщений:

Отправлено 16 Август 2019 - 18:47

Всем привет.

Пришло время установить сервер 11 версии в среде МСВС 5.0. Классическая установка и в конце, судя по всему, вываливание из-за отсутствия функции GOST в МСВС. Она в принципе отсутствует в МСВС 5.0. В Приложении, в перечне поддерживаемых осей данная ось поддерживается.

В связи с этим вопрос: как установить сервер (клиентов пока еще не успел поставить) в случае отсутствия функции GOST?

Скрин прилагаю...

 

65d469d349bf958870aa308278cb20e0.jpeg


Сообщение было изменено Jbanchic: 16 Август 2019 - 18:51


#2 Dmitry Mikhirev

Dmitry Mikhirev

    Member

  • Dr.Web Staff
  • 371 Сообщений:

Отправлено 16 Август 2019 - 18:59

В Приложении, в перечне поддерживаемых осей данная ось поддерживается.

Однако, судя по ошибке, запустить шансов нет. Нужна более свежая система, а именно — более свежая glibc.

#3 Afalin

Afalin

    Guru

  • Dr.Web Staff
  • 3 852 Сообщений:

Отправлено 16 Август 2019 - 18:59

GOST тут ни при чём. Проблема строкой выше.

Покажите вывод

uname -a

/lib/libc.so.6


Семь раз отрежь – один раз проверь

#4 Jbanchic

Jbanchic

    Newbie

  • Posters
  • 64 Сообщений:

Отправлено 16 Август 2019 - 19:03

GOST тут ни при чём. Проблема строкой выше.
Покажите вывод
uname -a
/lib/libc.so.6

fce8d5cd0c5413aeade8a40b234c1b92.jpeg

Сообщение было изменено Jbanchic: 16 Август 2019 - 19:05


#5 Kirill Polubelov

Kirill Polubelov

    Forth Thinker

  • Dr.Web Staff
  • 3 329 Сообщений:

Отправлено 16 Август 2019 - 19:04

Все "госты" как раз уже есть в либах сервера, но до них не дошли, не смогли загрузить /opt/drwcs/lib/libdrwnetwork-core.so, по причине "ELF file OS ABI invalid", glibc не той системы.


Сообщение было изменено Kirill Polubelov: 16 Август 2019 - 19:05

(exit 0)


#6 Afalin

Afalin

    Guru

  • Dr.Web Staff
  • 3 852 Сообщений:

Отправлено 16 Август 2019 - 19:04

И правда 2.5, тогда да, вообще без вариантов.

Из документации, видимо, не вычистили вовремя.


Все "госты" как раз уже есть в этой самой /opt/drwcs/lib/libdrwnetwork-core.so

Не в этой.


Семь раз отрежь – один раз проверь

#7 Jbanchic

Jbanchic

    Newbie

  • Posters
  • 64 Сообщений:

Отправлено 16 Август 2019 - 19:06

В Приложении, в перечне поддерживаемых осей данная ось поддерживается.

Однако, судя по ошибке, запустить шансов нет. Нужна более свежая система, а именно — более свежая glibc.

Если проблема в glibc, то тогда можно смело МСВС 5.0 из перечня поддерживаемых дистрибутивов исключать.

#8 Kirill Polubelov

Kirill Polubelov

    Forth Thinker

  • Dr.Web Staff
  • 3 329 Сообщений:

Отправлено 16 Август 2019 - 19:07

Может просто слинковано для чего-то другого, вручную было когда-то?


(exit 0)


#9 Afalin

Afalin

    Guru

  • Dr.Web Staff
  • 3 852 Сообщений:

Отправлено 16 Август 2019 - 19:08

Может просто слинковано для чего-то другого, вручную было когда-то?

Ты о чём?


Семь раз отрежь – один раз проверь

#10 Jbanchic

Jbanchic

    Newbie

  • Posters
  • 64 Сообщений:

Отправлено 16 Август 2019 - 19:09

Может просто слинковано для чего-то другого, вручную было когда-то?

Нет, дистрибутив родной, официальный, сертифицированный. Печально все.

#11 Afalin

Afalin

    Guru

  • Dr.Web Staff
  • 3 852 Сообщений:

Отправлено 16 Август 2019 - 19:12

Но, посмотрел, хотя б Astra Linux SE 1.3+ таки должны поддерживать, судя по версиям glibc.

Увы, ВНИИНС много лет назад протух.


Сообщение было изменено Afalin: 16 Август 2019 - 19:12

Семь раз отрежь – один раз проверь

#12 Jbanchic

Jbanchic

    Newbie

  • Posters
  • 64 Сообщений:

Отправлено 16 Август 2019 - 19:16

Но, посмотрел, хотя б Astra Linux SE 1.3+ таки должны поддерживать, судя по версиям glibc.
Увы, ВНИИНС много лет назад протух.


Протухнуть то он протух, а детище его древнючее еще пока используется. Получается последняя только 10-ка с 11-ми клиентами?

#13 Afalin

Afalin

    Guru

  • Dr.Web Staff
  • 3 852 Сообщений:

Отправлено 16 Август 2019 - 19:31

10 вроде бы да, она glibc 2.3.6 требует.


Сообщение было изменено Afalin: 16 Август 2019 - 19:32

Семь раз отрежь – один раз проверь

#14 Jbanchic

Jbanchic

    Newbie

  • Posters
  • 64 Сообщений:

Отправлено 16 Август 2019 - 19:45

10 вроде бы да, она glibc 2.3.6 требует.

Хорошо, для 11 версии какие требования к glibc?

#15 Afalin

Afalin

    Guru

  • Dr.Web Staff
  • 3 852 Сообщений:

Отправлено 16 Август 2019 - 19:52

Строго говоря, 2.11.3.


Семь раз отрежь – один раз проверь

#16 Jbanchic

Jbanchic

    Newbie

  • Posters
  • 64 Сообщений:

Отправлено 20 Август 2019 - 13:12

Строго говоря, 2.11.3.

Уважаемый. Подскажите, а к клиенту drweb-workstations_11.0.6-1810051457+mo~linux_amd64.run те же требования по glibc? Пробная установка проведена успешно, но при старте drweb-gui выдает ошибку сегментирования.

b1a9a34e9128a0dd43c8496cdbd9a004.jpeg

P.S. Установка проводилась в среде VMware workstation. С 10-м клиентом так прокатывало.


Сообщение было изменено Jbanchic: 20 Август 2019 - 13:13


#17 Dmitry Mikhirev

Dmitry Mikhirev

    Member

  • Dr.Web Staff
  • 371 Сообщений:

Отправлено 20 Август 2019 - 14:16

Подскажите, а к клиенту drweb-workstations_11.0.6-1810051457+mo~linux_amd64.run те же требования по glibc?

Нет. На клонах RHEL5, в том числе МСВС 5.0, он должен работать.
 

Пробная установка проведена успешно, но при старте drweb-gui выдает ошибку сегментирования.

А зачем Вы запускаете его под root?

Сообщение было изменено Dmitry Mikhirev: 20 Август 2019 - 14:19


#18 Jbanchic

Jbanchic

    Newbie

  • Posters
  • 64 Сообщений:

Отправлено 20 Август 2019 - 14:36

Нет. На клонах RHEL5, в том числе МСВС 5.0, он должен работать.

Даже бинарь из исходников собрал, как в случае с 10-кой... Но не запускается. Есть идеи?

 

А зачем Вы запускаете его под root?

Это тестовая виртуалка. На ней можно всё.

 

И все же..?



#19 Dmitry Mikhirev

Dmitry Mikhirev

    Member

  • Dr.Web Staff
  • 371 Сообщений:

Отправлено 20 Август 2019 - 14:40

Даже бинарь из исходников собрал, как в случае с 10-кой...

Не понял, какой бинарь?

 

И все же..?

И всё же, что будет, если запустить от имени непривилегированного пользователя?



#20 Jbanchic

Jbanchic

    Newbie

  • Posters
  • 64 Сообщений:

Отправлено 20 Август 2019 - 14:52

Не понял, какой бинарь?

drweb-spider-kmod

 

И всё же, что будет, если запустить от имени непривилегированного пользователя?

755f08e1a5d0247b4f27d70d2589eead.jpeg




Читают тему: 0

0 пользователей, 0 гостей, 0 скрытых