Перейти к содержимому


Фото
- - - - -

drweb 6.0.2 при проверке больших писем отваливается


  • Please log in to reply
8 ответов в этой теме

#1 l-gri

l-gri

    Newbie

  • Posters
  • 5 Сообщений:

Отправлено 03 Июнь 2013 - 15:28

Здравствуйте....м.б. кто-нибудь сталкивался с тем, что когда drweb пытается проверить большое письмо, то происходит сбой и обрушивается процесс maild и monitor не может его перестартовать и сам помирает

 

Mon Jun  3 14:58:51 2013 [81926] monitor INFO component "drweb-maild" fault, pid
=2903
Mon Jun  3 14:58:52 2013 [81926] monitor ERROR internal error in main loop: wait
pid(2903, ..) error: No child processes
Mon Jun  3 14:58:53 2013 [81926] monitor WARN one component from application MAI
LD is fault. The application will be stopped
Mon Jun  3 14:58:53 2013 [81926] monitor ERROR internal error in main loop: wait
pid(2922, ..) error: No child processes
2013-Jun-03 15:58:52 [b3e] agent.worker-2 INFO [Agent] Got SIGTERM, will termina
te.
Mon Jun  3 15:58:51 2013 [16384] monitor INFO Monitor::terminate(): arrived SIGT
ERM
Mon Jun  3 15:58:54 2013 [16384] monitor INFO application "AGENT" has been stopp
ed
Mon Jun  3 15:58:54 2013 [16384] monitor INFO Dr.Web ® Components Monitor shut
down
 

 

 

 



#2 valya krasnoglazova

valya krasnoglazova

    Newbie

  • Dr.Web Staff
  • 94 Сообщений:

Отправлено 04 Июнь 2013 - 13:09

Добрый день.

 

Чтобы понять, в чем именно причина нужен семпл письма, логи с попыткой обработки, по возможности, в debug-режиме + настройки drweb-maild и плагинов.

 

1. Debug режим для логирования включается в etc/drweb/maild_mta.conf, секция Logging.

2. В etc/drweb/agent.conf, etc/drweb/monitor.conf также желательно выставить Logging/Level=debug и перенаправить логи всех компонентов в один файл (см. параметры Logging/FileName, SyslogFacility).

3. Далее выполнить drweb-monitor reload и попробовать отправить семпл,  полученный debug-лог с момента reload отправить в ЛС  вместе с конфигами maild_mta.conf, plugin_*.conf, agent.conf, monitor.conf и семплом.

 

Также нужны: архитектура системы, версия ОС, версии установленных drweb-пакетов, + если подключен антивирусный плагин etc/drweb/drweb32.ini



#3 l-gri

l-gri

    Newbie

  • Posters
  • 5 Сообщений:

Отправлено 05 Июнь 2013 - 08:03

root@npost:/home/lena/drweb# uname -a
Linux npost 2.4.20 #1 Thu Aug 14 21:59:37 MSD 2003 i686 unknown
 

sendmail 8.12.9

 

И еще одна проблема: ограничили объем проверяемых сообщений не больше 50МБ, но почему-то он на это не реагирует и проверяет все подряд вне зависимости от объема, после чего  тихо умирает :)

 

письмо с файлом 29МБ (общий размер сообщения - 39МБ) проверилось ...., а файл 40 МБ ( и соответственно размер письма был 54МБ) не проверился и вызвал ошибку в работе ( см. логи) 

Прикрепленные файлы:

  • Прикрепленный файл  drweb.rar   19,48К   4 Скачано раз


#4 GrayCat

GrayCat

    Newbie

  • Posters
  • 95 Сообщений:

Отправлено 05 Июнь 2013 - 17:02

Linux npost 2.4.20 #1 Thu Aug 14 21:59:37 MSD 2003 i686 unknown

это что, допотопное ядро 2.4 изготовления 2003 года ?

 

странно, что вообще работает



#5 valya krasnoglazova

valya krasnoglazova

    Newbie

  • Dr.Web Staff
  • 94 Сообщений:

Отправлено 05 Июнь 2013 - 17:26

да на ядрах 2.4  работа  комплекса на предмет производительности не тестируется, и нестабильна, отсюда сюрпризы,  желательно переезжать на более свежие дистрибутивы.   

 

спасибо за конфиги и логи, у себя попробую воспроизвести, но, даже если баг, касательно фикса ничего не могу пока сказать


Сообщение было изменено valya krasnobaeva: 05 Июнь 2013 - 17:26


#6 l-gri

l-gri

    Newbie

  • Posters
  • 5 Сообщений:

Отправлено 06 Июнь 2013 - 07:25

спасибо за ответы....это у нас старая тестовая машина....а на ядре 2.6.18 будет ли это работать или тоже не проверялось ?



#7 l-gri

l-gri

    Newbie

  • Posters
  • 5 Сообщений:

Отправлено 06 Июнь 2013 - 07:40

еще раз посмотрели системные требования:

Требования к версии ядра и библиотеке glibc зависят от типа
установочного пакета:
универсальный пакет для UNIX систем (Linux x86) - версия
ядра 2.4.x, версия glibc2.2 (не рекомендуется) и выше,
либо версия ядра 2.6.x, версия glibc 2.3 и выше;

 

к чему относятся слова (не рекомендуется) к ядру или glibc???

 

у нас получается ядро 2.4.20, а glibc-2.3.1......



#8 GrayCat

GrayCat

    Newbie

  • Posters
  • 95 Сообщений:

Отправлено 06 Июнь 2013 - 09:08

похоже на то, что "не рекомендуется" относится к версии glibc

вот только...

например, у меня в стабильном дебиане (squeeze нынче уже, правда, old stable):

GNU C Library (Debian EGLIBC 2.11.3-4) stable release version 2.11.3

:D



#9 Mikhail Khokhlov

Mikhail Khokhlov

    Member

  • Dr.Web Staff
  • 299 Сообщений:

Отправлено 06 Июнь 2013 - 10:58

к чему относятся слова (не рекомендуется) к ядру или glibc???

Не рекомендуется относится к glibc2.2

у нас получается ядро 2.4.20, а glibc-2.3.1......

Работать комплекс в такой конфигурации должен, но вот на сколько стабильно, особенно под нагрузкой, - вопрос.

Желательно, конечно, использовать систему поновее.

а на ядре 2.6.18 будет ли это работать

Будет.




Читают тему: 0

0 пользователей, 0 гостей, 0 скрытых