Перейти к содержимому


Фото
- - - - -

Windows Subsystem for Linux : pas d'acces à LAMP


  • Please log in to reply
2 ответов в этой теме

#1 Manuel

Manuel

    Newbie

  • Posters
  • 9 Сообщений:

Отправлено 16 Август 2018 - 16:39

Bonjour,

 

Je viens vers vous pour un problème que je n'arrive pas à résoudre :

 

Aujourd'hui j'ai installé LAMP sur WSL à l'aide d'un tuto et je ne peut accéder au localhost ( WSL ) qu'en arrêtant mon firewall (ce qui est embêtant.)

 

Pourtant il m'a semblé que le firewall m'a demandé d'inclure des droits lors le lancement d'apache...

 

Il y a peut-être une chose qui m'échappe... 

 

pour infos :

 

System Information (local)


Computer name:
Windows version: Windows 10 , 10.0, build: 17134 (version 10.0.17134.228 plus précisément)
Windows dir: C:\WINDOWS
Hardware: SATELLITE L50-B, TOSHIBA, Type2 - Board Vendor Name1, Type2 - Board Product Name1
CPU: GenuineIntel Intel® Core™ i7-4500U CPU @ 1.80GHz Intel586, level: 6
4 logical processors, active mask: 15
RAM: 8506195968 bytes total

 

et mon WSL :

 

Distributor ID: Ubuntu
Description:    Ubuntu 16.04.5 LTS
Release:        16.04
Codename:       xenial

 

En attente de votre réponse, merci d'avance.


Сообщение было изменено Manuel: 16 Август 2018 - 16:41


#2 Manuel

Manuel

    Newbie

  • Posters
  • 9 Сообщений:

Отправлено 16 Август 2018 - 16:55

re,

 

Dernière verification :

Je viens de supprimer les règles d'apache et relancé le service, DrWeb détecte bien le lancement du service, j'ai tout accepté sur les règles, rien n'y fait.



#3 Manuel

Manuel

    Newbie

  • Posters
  • 9 Сообщений:

Отправлено 16 Август 2018 - 17:03

re,

 

et pour info j'ai suivi le tuto :

https://medium.com/@ssharizal/how-to-install-lamp-stack-server-on-windows-subsystem-linux-wsl-windows-10-133419c22473

 

à ceci près, au lieu compléter /etc/apache2/apache2.conf avec ceci :

Servername localhost

AcceptFilter http none

j'ai complété avec :

#
# fix error in WSL (Protocol not available: AH00076: Failed to enable APR_TCP_DEFER_ACCEPT)
# https://github.com/Microsoft/WSL/issues/1953#issuecomment-295370994
#
AcceptFilter http none
AcceptFilter https none

et lancé ces deux lignes de commandes :

sudo a2enmod rewrite
sudo service apache2 restart

sans cela mon installation ne marchait pas.


Сообщение было изменено Manuel: 16 Август 2018 - 17:05



Читают тему: 0

0 пользователей, 0 гостей, 0 скрытых