Перейти к содержимому


Фото
- - - - -

Spideragent 6.0(x86) + Win2k3 = ошибка через несколько суток?


  • Please log in to reply
25 ответов в этой теме

#1 spezialist

spezialist

    Newbie

  • Posters
  • 66 Сообщений:

Отправлено 22 Июнь 2010 - 08:34

Привет всем!

На прошлой неделе обновил на двух серверах с MS Windows 2003 R2 SP2 Std. (x86) антивирус с 5-й на 6-ю версию. Сервера выполнены на разных аппаратных платформах. Сервера работают в режиме 24/7/365 (если такое вообще можно сказать про серверные продукты M$ :-)))))).
Вчера заметил на обоих серверах, при входе от имени обычного юзера и админа, что иконка SpiderAgent вдруг с красным крестиком, мол ошибка. Навожу мышкой на иконку и получаю: Spider Guard ошибка, Самозащита включена, Последнее обновление неизвестно. В самом контектном меню агента Spider Guard отображается отключенным. Смотрю логи: spiderg3.log имеет размер 9972КБайт и дату последней модификации 21.06.2010 09:35 по Киевскому времени. Лог-файл обновления имеет нормальную дату модификации, т.е. проверив папку с обновлениями, убедился, что обновления выполняются успешно и они актуальны. В памяти все процессы, относящиеся к антивирусу также присутствуют как для движка так и для агента. В системных журналах ничего подозрительного не заметил.
Пока это все что смог обнаружить, а перегружать сервера пока не получается. Думаю что после ребута все встанет на свои места, но почему так произошло -- вопрос.

Заранее благодарю за поддержку.
Чорнобиль форева!

#2 pig

pig

    Бредогенератор

  • Helpers
  • 10 651 Сообщений:

Отправлено 22 Июнь 2010 - 08:46

Может, поискать ответ в логах? Включая журнал событий Windows.
Почтовый сервер Eserv тоже работает с Dr.Web

#3 spezialist

spezialist

    Newbie

  • Posters
  • 66 Сообщений:

Отправлено 22 Июнь 2010 - 09:37

Может, поискать ответ в логах? Включая журнал событий Windows.


:) , так я в первую очередь это и сделал (я об этом уже писал). И ничего подозрительного не нашел, к сожалению.
Заранее благодарю за поддержку.
Чорнобиль форева!

#4 pig

pig

    Бредогенератор

  • Helpers
  • 10 651 Сообщений:

Отправлено 22 Июнь 2010 - 10:01

Телепаты сами знаете где. В порядке бреда могу предложить выбрать момент и свалить систему в BSOD с созданием полного дампа. Авось, разработчики там что-нибудь интересное увидят.
Почтовый сервер Eserv тоже работает с Dr.Web

#5 spezialist

spezialist

    Newbie

  • Posters
  • 66 Сообщений:

Отправлено 22 Июнь 2010 - 10:27

Телепаты сами знаете где. В порядке бреда могу предложить выбрать момент и свалить систему в BSOD с созданием полного дампа. Авось, разработчики там что-нибудь интересное увидят.


Я все это прекрасно понимаю, и тут публикую пока свои наблюдения по мере возможности. Я ж не претендую на сиюминутное решение моей проблемы, знаю что без фактов разобраться невозможно. Возможно, что не только у меня проявляется такой баг, тем более что он возник на двух серверах почти одновременно. По крайней мере симптомы одинаковы (серваки на разных конторах и никак не связаны друг с другом).
Перегрузить или создать дамп пока не могу -- серваки постоянно в работе.
О логах уже говорил -- все нормально, кроме того заметил, что лог спайдера сегодня отмодифицировался, т.е. похоже что сам спайдер жив и даже проверяет файлы на наличие вирусов. И еще заметил одну особенность спайдерагента: в момент входа в систему значек агента отображается нормально, т.е. без красного крестика и если успеть навести мышку, то тоже можно увидеть нормальное состояние компонентов, мол все работает. Но затем через секунду-другую иконка становится с красным крестиком со всеми вытекающими.
Пока это все. Если что будет новое -- отпишу.
Заранее благодарю за поддержку.
Чорнобиль форева!

#6 spezialist

spezialist

    Newbie

  • Posters
  • 66 Сообщений:

Отправлено 23 Июнь 2010 - 08:05

Перезагрузил сегодня один из серверов. Поведение иконки агента нормализовалось. Теперь будем дальше посмотреть :) .
Заранее благодарю за поддержку.
Чорнобиль форева!

#7 Goldman

Goldman

    Newbie

  • Posters
  • 7 Сообщений:

Отправлено 26 Август 2010 - 17:15

Привет всем!

На прошлой неделе обновил на двух серверах с MS Windows 2003 R2 SP2 Std. (x86) антивирус с 5-й на 6-ю версию. Сервера выполнены на разных аппаратных платформах. Сервера работают в режиме 24/7/365 (если такое вообще можно сказать про серверные продукты M$ :-)))))).
Вчера заметил на обоих серверах, при входе от имени обычного юзера и админа, что иконка SpiderAgent вдруг с красным крестиком, мол ошибка. Навожу мышкой на иконку и получаю: Spider Guard ошибка, Самозащита включена, Последнее обновление неизвестно. В самом контектном меню агента Spider Guard отображается отключенным. Смотрю логи: spiderg3.log имеет размер 9972КБайт и дату последней модификации 21.06.2010 09:35 по Киевскому времени. Лог-файл обновления имеет нормальную дату модификации, т.е. проверив папку с обновлениями, убедился, что обновления выполняются успешно и они актуальны. В памяти все процессы, относящиеся к антивирусу также присутствуют как для движка так и для агента. В системных журналах ничего подозрительного не заметил.
Пока это все что смог обнаружить, а перегружать сервера пока не получается. Думаю что после ребута все встанет на свои места, но почему так произошло -- вопрос.


Подтверждаю проблему! У меня Ms Windows 2003 R2 SP2 Enterprise Edition (x86), терминальный сервер... к вышесказанному добавлю что после падения Spider Guard в менеджере лицензий не отображаются сведения о лицензии - см. скриншоты!

Ранее на сервере стояла 5 версия, но она замучала мне BSOD'ами... вот решил перейти на 6 версию :(
На выходных планирую рестартнуть сервер - поставлю уровень лога в отладочный режим...

Прикрепленные файлы:



#8 userr

userr

    The Master

  • Moderators
  • 16 310 Сообщений:

Отправлено 26 Август 2010 - 17:37

Goldman
в реальности ключ есть в папке Доктора? когда истекает?
соберите логи с машины http://people.drweb.com/people/yudin/dwsysinfo.exe и с ними в Поддержку и\или сюда.

#9 Goldman

Goldman

    Newbie

  • Posters
  • 7 Сообщений:

Отправлено 26 Август 2010 - 18:05

Goldman
в реальности ключ есть в папке Доктора? когда истекает?


В реальности есть... достаточно перезагрузить сервер и все в порядке, истекает 25.11.2010!

соберите логи с машины http://people.drweb.com/people/yudin/dwsysinfo.exe и с ними в Поддержку и\или сюда.


Лови...

Прикрепленные файлы:



#10 Goldman

Goldman

    Newbie

  • Posters
  • 7 Сообщений:

Отправлено 26 Август 2010 - 18:44

Интересные результаты! Решил проверить работает ли Spider Guard... подсунул eicar эффекта не заметил - логи курил, но не внимательно. Решил проверить eicar сканером Dr.Web - все в порядке, определяется, закрыл сканер... и тут заметил что иконка в трее (о чудо!) стала нормальной! Пробежался по пунктам меню - все вроде работает как надо (менеджер лицензий, статистика Spider Guard). Покурил лог внимательно - обнаружил там мой eicar, Spider Guard его заблокировал! :(

#11 HHH

HHH

    Massive Poster

  • Posters
  • 2 714 Сообщений:

Отправлено 26 Август 2010 - 18:50

Подтверждаю проблему!

Судя по логу spider что-то проверяет. Если ему в этот момент кинуть тестовый вирус (http://www.eicar.org/download/eicar.com) - какая будет реакция?

P.S. вижу что опоздал.

Значит это только GUI отваливается - не сильно критично :( Обращайтесь в техподдержку, пусть разбираются.

#12 an

an

    Newbie

  • Posters
  • 21 Сообщений:

Отправлено 26 Август 2010 - 19:16

посмотрите состояние службы dwengine

#13 Goldman

Goldman

    Newbie

  • Posters
  • 7 Сообщений:

Отправлено 26 Август 2010 - 19:29

посмотрите состояние службы dwengine


Работает

#14 an

an

    Newbie

  • Posters
  • 21 Сообщений:

Отправлено 26 Август 2010 - 20:34

посмотрите состояние службы dwengine


Работает


У меня такое было после переагрузки и установки обновлений от 11 августа. Причиной являлся тайм-аут запуска службы.
Когда запустил ручками - лицензия стала отображаться, значок спайдера стал зеленым.

#15 Konstantin Yudin

Konstantin Yudin

    Смотрящий

  • Dr.Web Staff
  • 17 970 Сообщений:

Отправлено 27 Август 2010 - 14:39

Обращайтесь в техподдержку, пусть разбираются.

не нужно. мы работаем над фиксом. проблема актуальна для терминальных серверов
With best regards, Konstantin Yudin
Doctor Web, Ltd.

#16 uncle_ck

uncle_ck

    Newbie

  • Members
  • 2 Сообщений:

Отправлено 05 Октябрь 2010 - 14:04

Обращайтесь в техподдержку, пусть разбираются.

не нужно. мы работаем над фиксом. проблема актуальна для терминальных серверов


доброго времени суток!
есть ли надежда на решение проблемы, отпадает SpiderGuard и менеджер лицензий теряет ключ, после перезагрузки все нормализуется, сами понимаете, перезагружать сервер несколько раз в день нет возможности

2008 Сервер х64
Др.Веб Версия 6.0.2.07290 х64

#17 HHH

HHH

    Massive Poster

  • Posters
  • 2 714 Сообщений:

Отправлено 05 Октябрь 2010 - 15:40

есть ли надежда на решение проблемы, отпадает SpiderGuard и менеджер лицензий теряет ключ, после перезагрузки все нормализуется, сами понимаете, перезагружать сервер несколько раз в день нет возможности

Так вроде выяснили, что это только GUI отпадает. Из-за таких мелочей сервер точно не стоит перезагружать.
Проблема не срочная. С очередной пачкой исправлений решат. Думаю где-то через пол года.

#18 userr

userr

    The Master

  • Moderators
  • 16 310 Сообщений:

Отправлено 05 Октябрь 2010 - 16:02

uncle_ck
Сообщение #8

#19 Konstantin Yudin

Konstantin Yudin

    Смотрящий

  • Dr.Web Staff
  • 17 970 Сообщений:

Отправлено 05 Октябрь 2010 - 18:38

доброго времени суток!
есть ли надежда на решение проблемы, отпадает SpiderGuard и менеджер лицензий теряет ключ, после перезагрузки все нормализуется, сами понимаете, перезагружать сервер несколько раз в день нет возможности

2008 Сервер х64
Др.Веб Версия 6.0.2.07290 х64

фикс уже в тестлабе. так что ждем отмашки
With best regards, Konstantin Yudin
Doctor Web, Ltd.

#20 uncle_ck

uncle_ck

    Newbie

  • Members
  • 2 Сообщений:

Отправлено 06 Октябрь 2010 - 11:35

uncle_ck
Сообщение #8


userr, а что именно, то что др.веб относится или ВСЕ? ;)


Читают тему: 0

0 пользователей, 0 гостей, 0 скрытых