Перейти к содержимому


Фото
- - - - -

перестали обновляться агенты Dr Web agent for windows


  • Закрыто Тема закрыта
40 ответов в этой теме

#1 Сергей_64

Сергей_64

    Newbie

  • Posters
  • 50 Сообщений:

Отправлено 01 Февраль 2017 - 07:19

Это началось вчера ночью, думал сегодня обновятся, но снова же такая ерунда: критическая ошибка:проблема обновления, и все агенты на станциях не могут обновиться. Что может быть такое?

Прикрепленные файлы:



#2 maxic

maxic

    Keep yourself alive

  • Moderators
  • 12 278 Сообщений:

Отправлено 01 Февраль 2017 - 09:24

Сергей_64, может быть, в логи заглянуть?



#3 Сергей_64

Сергей_64

    Newbie

  • Posters
  • 50 Сообщений:

Отправлено 01 Февраль 2017 - 09:45

Сергей_64, может быть, в логи заглянуть?

Файл весит больше 15 мб, давай почту, скину на гугл диск



#4 Nenya Amo

Nenya Amo

    Advanced Member

  • Posters
  • 732 Сообщений:

Отправлено 01 Февраль 2017 - 10:18

Файл весит больше 15 мб

в облако загрузите и ссылку на отчёт сюда.


мой девиз - служение злу, как у котика..


#5 Сергей_64

Сергей_64

    Newbie

  • Posters
  • 50 Сообщений:

Отправлено 01 Февраль 2017 - 10:25

 

Файл весит больше 15 мб

в облако загрузите и ссылку на отчёт сюда.

 

https://drive.google.com/open?id=0B9Mmzyd-OyYpMHpad1pzUS1NblU



#6 maxic

maxic

    Keep yourself alive

  • Moderators
  • 12 278 Сообщений:

Отправлено 01 Февраль 2017 - 10:30

20170131 12:32:30 [ERR] [Context ] Specify the correct folder repository or update it!
20170131 12:32:30 [ERR] [Updater ] Updater failed. Repository is invalid!
20170131 12:32:30 [INF] [  Main  ] Updater has finished. Exit code = 10. Info: Repository is invalid!

 

20170131 14:51:09 [INF] [ Loader ] Updater will update self!
20170131 14:51:09 [INF] [ Loader ] TOTAL SIZE TO DOWNLOAD IS 1608880 BYTES
20170131 14:51:09 [INF] [ Loader ] Download file script.lua.lzma from C:/ProgramData/Doctor Web/Updater/TempES/script.lua.lzma to C:/PROGRA~2/DOCTOR~1/Updater/repo/script.lua.lzma( 9518 bytes )
20170131 14:51:09 [INF] [ Repodb ] Saving file repodb.xml
20170131 14:51:09 [ERR] [Updater ] loader error: boost::filesystem::copy: Такой запрос не поддерживается: "C:\ProgramData\Doctor Web\Updater\TempES\script.lua.lzma", "C:/PROGRA~2/DOCTOR~1/Updater/repo\script.lua.lzma.cache;7ee7a5a9f8173c17dc9c8cbf9afea3847f2689ac6ecba38fe970d5e33310391b"
20170131 14:51:09 [ERR] [Updater ] Updater failed.
20170131 14:51:09 [INF] [  Main  ] Updater has finished. Exit code = 2



#7 Сергей_64

Сергей_64

    Newbie

  • Posters
  • 50 Сообщений:

Отправлено 01 Февраль 2017 - 10:45

20170131 12:32:30 [ERR] [Context ] Specify the correct folder repository or update it!
20170131 12:32:30 [ERR] [Updater ] Updater failed. Repository is invalid!
20170131 12:32:30 [INF] [  Main  ] Updater has finished. Exit code = 10. Info: Repository is invalid!

 

20170131 14:51:09 [INF] [ Loader ] Updater will update self!
20170131 14:51:09 [INF] [ Loader ] TOTAL SIZE TO DOWNLOAD IS 1608880 BYTES
20170131 14:51:09 [INF] [ Loader ] Download file script.lua.lzma from C:/ProgramData/Doctor Web/Updater/TempES/script.lua.lzma to C:/PROGRA~2/DOCTOR~1/Updater/repo/script.lua.lzma( 9518 bytes )
20170131 14:51:09 [INF] [ Repodb ] Saving file repodb.xml
20170131 14:51:09 [ERR] [Updater ] loader error: boost::filesystem::copy: Такой запрос не поддерживается: "C:\ProgramData\Doctor Web\Updater\TempES\script.lua.lzma", "C:/PROGRA~2/DOCTOR~1/Updater/repo\script.lua.lzma.cache;7ee7a5a9f8173c17dc9c8cbf9afea3847f2689ac6ecba38fe970d5e33310391b"
20170131 14:51:09 [ERR] [Updater ] Updater failed.
20170131 14:51:09 [INF] [  Main  ] Updater has finished. Exit code = 2

И что это значит? Что я должен сделать?



#8 Kirill Polubelov

Kirill Polubelov

    Forth Thinker

  • Dr.Web Staff
  • 3 267 Сообщений:

Отправлено 01 Февраль 2017 - 11:25

В ынедавно на этой станции включили спящий_режим/гибернацию?


(exit 0)


#9 Сергей_64

Сергей_64

    Newbie

  • Posters
  • 50 Сообщений:

Отправлено 01 Февраль 2017 - 11:42

В ынедавно на этой станции включили спящий_режим/гибернацию?

Я не включал режим гибернации на этой станции. а причем тут это?



#10 Kirill Polubelov

Kirill Polubelov

    Forth Thinker

  • Dr.Web Staff
  • 3 267 Сообщений:

Отправлено 01 Февраль 2017 - 12:45

По логу, похоже, проясняется, что не при чём.

Хотя и есть множество сигналов суспенда ОС, но, они не должны были повллиять. Апдейтер запускался и завершался, без прерываний на "засыпание", как показалось в начале.

Если учесть, что вы говорите, что это на всех станциях, то без лога сервера (drwcsd.log) не обойтись. Возможно, что-то с репозиторием на сервере. Но, обещать ничего нельзя, если лог не дебажный, но, для начала можно и такой, какой есть.


(exit 0)


#11 Сергей_64

Сергей_64

    Newbie

  • Posters
  • 50 Сообщений:

Отправлено 01 Февраль 2017 - 13:22

По логу, похоже, проясняется, что не при чём.

Хотя и есть множество сигналов суспенда ОС, но, они не должны были повллиять. Апдейтер запускался и завершался, без прерываний на "засыпание", как показалось в начале.

Если учесть, что вы говорите, что это на всех станциях, то без лога сервера (drwcsd.log) не обойтись. Возможно, что-то с репозиторием на сервере. Но, обещать ничего нельзя, если лог не дебажный, но, для начала можно и такой, какой есть.

https://drive.google.com/open?id=0B9Mmzyd-OyYpb1NkZmdXcWNobTg
вот ссылка на лог сервера



#12 Kirill Polubelov

Kirill Polubelov

    Forth Thinker

  • Dr.Web Staff
  • 3 267 Сообщений:

Отправлено 01 Февраль 2017 - 13:35

20170201.142023.76 db2 [01384 0668] wrk:2  [Update] tcp://36.0.6.14:49272/st: Update is not enabled at this time
20170201.142023.76 db2 [01384 0668] wrk:2  [Update] tcp://36.0.6.48:1148/st: Update is not enabled at this time
20170201.142023.76 db2 [01384 0668] wrk:2  [Update] tcp://36.0.7.78:1210/st: Update is not enabled at this time
20170201.142023.76 db2 [01384 0668] wrk:2  [Update] tcp://36.0.7.7:1156/st: Update is not enabled at this time
20170201.142023.76 db2 [01384 0668] wrk:2  [Update] tcp://36.0.5.96:49273/st: Update is not enabled at this time
20170201.142023.76 db2 [01384 0668] wrk:2  [Update] tcp://36.0.7.168:1167/st: Update is not enabled at this time
20170201.142023.76 db2 [01384 0668] wrk:2  [Update] tcp://36.0.5.125:49287/st: Update is not enabled at this time
20170201.142023.76 db2 [01384 0670] wrk:4  [Update] tcp://36.0.6.47:62001/st: Update is not enabled at this time
20170201.142024.05 db2 [01384 0670] wrk:4  [Update] tcp://36.0.7.61:1135/st: Update is not enabled at this time
20170201.142024.05 db2 [01384 0668] wrk:2  [Update] tcp://36.10.64.64:37369/st: Update is not enabled at this time

 

и т.д.

 

Запретили апдейты для станций, на сервере.


(exit 0)


#13 Сергей_64

Сергей_64

    Newbie

  • Posters
  • 50 Сообщений:

Отправлено 01 Февраль 2017 - 13:40

20170201.142023.76 db2 [01384 0668] wrk:2  [Update] tcp://36.0.6.14:49272/st: Update is not enabled at this time
20170201.142023.76 db2 [01384 0668] wrk:2  [Update] tcp://36.0.6.48:1148/st: Update is not enabled at this time
20170201.142023.76 db2 [01384 0668] wrk:2  [Update] tcp://36.0.7.78:1210/st: Update is not enabled at this time
20170201.142023.76 db2 [01384 0668] wrk:2  [Update] tcp://36.0.7.7:1156/st: Update is not enabled at this time
20170201.142023.76 db2 [01384 0668] wrk:2  [Update] tcp://36.0.5.96:49273/st: Update is not enabled at this time
20170201.142023.76 db2 [01384 0668] wrk:2  [Update] tcp://36.0.7.168:1167/st: Update is not enabled at this time
20170201.142023.76 db2 [01384 0668] wrk:2  [Update] tcp://36.0.5.125:49287/st: Update is not enabled at this time
20170201.142023.76 db2 [01384 0670] wrk:4  [Update] tcp://36.0.6.47:62001/st: Update is not enabled at this time
20170201.142024.05 db2 [01384 0670] wrk:4  [Update] tcp://36.0.7.61:1135/st: Update is not enabled at this time
20170201.142024.05 db2 [01384 0668] wrk:2  [Update] tcp://36.10.64.64:37369/st: Update is not enabled at this time

 

и т.д.

 

Запретили апдейты для станций, на сервере.

Буду очень признателен вам, как мне разрешить обновления станциям?



#14 Kirill Polubelov

Kirill Polubelov

    Forth Thinker

  • Dr.Web Staff
  • 3 267 Сообщений:

Отправлено 01 Февраль 2017 - 13:41

Но, парочке станций, похоже разрешено, видимо у них персональные настройки. Должны обновляться станции:
36.0.7.78
36.0.7.163
36.0.5.77


(exit 0)


#15 Kirill Polubelov

Kirill Polubelov

    Forth Thinker

  • Dr.Web Staff
  • 3 267 Сообщений:

Отправлено 01 Февраль 2017 - 13:44

Буду очень признателен вам, как мне разрешить обновления станциям?

 

Веб-интерфейс, АВ-сеть, группа Everyone (начните с ее проверки), раздел "Ограничения обновлений", поле "Ограничение обновлений" должно быть "Без ограничений"

И таблица времени/дат - зеленая.


Сообщение было изменено Kirill Polubelov: 01 Февраль 2017 - 13:44

(exit 0)


#16 Сергей_64

Сергей_64

    Newbie

  • Posters
  • 50 Сообщений:

Отправлено 01 Февраль 2017 - 13:51

 

Буду очень признателен вам, как мне разрешить обновления станциям?

 

Веб-интерфейс, АВ-сеть, группа Everyone (начните с ее проверки), раздел "Ограничения обновлений", поле "Ограничение обновлений" должно быть "Без ограничений"

И таблица времени/дат - зеленая.

 

Спасибо, изначально на это подумал и просмотрел, Поле всё зелёное. Аналогично должны быть и другие группы, верно?



#17 Kirill Polubelov

Kirill Polubelov

    Forth Thinker

  • Dr.Web Staff
  • 3 267 Сообщений:

Отправлено 01 Февраль 2017 - 14:15

Верно. Для всех групп и станций, если для них заданы персональные (отличные от группы Everyone) настройки "Огранияения обновлений"
.

Все группы/станции с персональными настройками должны отображаться в служебнойгруппе "Configured" в дереве АВ-сети.


(exit 0)


#18 Сергей_64

Сергей_64

    Newbie

  • Posters
  • 50 Сообщений:

Отправлено 01 Февраль 2017 - 14:40

Верно. Для всех групп и станций, если для них заданы персональные (отличные от группы Everyone) настройки "Огранияения обновлений"
.

Все группы/станции с персональными настройками должны отображаться в служебнойгруппе "Configured" в дереве АВ-сети.

Спасибо, обновления начали по-потихоньку ставится на машины.



#19 Kirill Polubelov

Kirill Polubelov

    Forth Thinker

  • Dr.Web Staff
  • 3 267 Сообщений:

Отправлено 01 Февраль 2017 - 14:55

Если не сложно, не могли бы вы посмотреть на одной из машин, на которой проблема пока осталась, в каталоге "%ProgramData%\Doctor Web\Updater" есть ли каталог TempES и если есть, прислать его содержимое в месте с логами из "%ProgramData%\Doctor Web\Logs".

Или можно просто "%ProgramData%\Doctor Web" целиком, архивом.

 

Хочется докопаться до причины, потому как при запрете обновлений, ошибок обновления возникать не должно.

Включение обновлений, это, по сути, обходной путь, пригодный только тогда, когда вы на самом деле, отключать обновления и не хотели.


Сообщение было изменено Kirill Polubelov: 01 Февраль 2017 - 14:56

(exit 0)


#20 Сергей_64

Сергей_64

    Newbie

  • Posters
  • 50 Сообщений:

Отправлено 01 Февраль 2017 - 15:23

Если не сложно, не могли бы вы посмотреть на одной из машин, на которой проблема пока осталась, в каталоге "%ProgramData%\Doctor Web\Updater" есть ли каталог TempES и если есть, прислать его содержимое в месте с логами из "%ProgramData%\Doctor Web\Logs".

Или можно просто "%ProgramData%\Doctor Web" целиком, архивом.

 

Хочется докопаться до причины, потому как при запрете обновлений, ошибок обновления возникать не должно.

Включение обновлений, это, по сути, обходной путь, пригодный только тогда, когда вы на самом деле, отключать обновления и не хотели.

Вот что интересно, что папки tempes как таковой нет, поэтому кидаю папку на диск и вот ссылка: https://drive.google.com/open?id=0B9Mmzyd-OyYpbHljamJRTEE0ejg




Читают тему: 0

0 пользователей, 0 гостей, 0 скрытых