Перейти к содержимому


Фото
- - - - -

Dr.Web version 9 firewall cause ipv6 unaccessable


  • Please log in to reply
13 ответов в этой теме

#1 copyrighthero

copyrighthero

    Newbie

  • Posters
  • 8 Сообщений:

Отправлено 21 Март 2014 - 06:54

Hi, I just installed version 9 of dr.web, but after reboot the ipv6 network is unaccessable. I checked internet adapter, it says '' no internet connction'' in ipv6 column,but once i disabled dr.web's firewall and connect again, ipv6 seems to work again. I highly depend on ipv6 connections here, so i wonder if there is a solution to this?
and i vaguely remember that ipv6 network works fine with dr.web version8...
thank you guys for your help!

#2 Dmitry Volkov

Dmitry Volkov

    Poster

  • Dr.Web Staff
  • 1 034 Сообщений:

Отправлено 21 Март 2014 - 09:50

Hi!
 
Please send me detailed logs of Dr.Web components (with Firewall detailed log).
We will investigate this problem.
 
Or contact Dr.Web support (the best way).


#3 Diana Lebedeva

Diana Lebedeva

    ССЗБ

  • Dr.Web Staff
  • 1 054 Сообщений:

Отправлено 21 Март 2014 - 10:03

Good afternoon,

thank you for your report, could you please switch on the detailed logging of Firewall in Settings (Settings -> Main -> Advanced -> Report: Change; and also if you will need to reboot to reproduce the problem, could you please check the "Continue detailed logging after reboot" checkbox)? Save your changes, reproduce the problem (switch On firewall, and and switch you network connection off\on  if necessary). You can find the .pcap log file in the root of your system drive. Please send this log to me. 

 

Also could you please answer the following question:

1)  In Firewall -> Settings -> Interfaces choose the "Allow all" rule for your Network interface, save the changes. Will it solve the problem? 


Сообщение было изменено Diana Lebedeva: 21 Март 2014 - 10:04

— Чарли, нам нужно поговорить. Есть проблема.

— Почему ты никогда не говоришь «есть решение»?


#4 copyrighthero

copyrighthero

    Newbie

  • Posters
  • 8 Сообщений:

Отправлено 21 Март 2014 - 15:02

 

Hi!
 
Please send me detailed logs of Dr.Web components (with Firewall detailed log).
We will investigate this problem.
 
Or contact Dr.Web support (the best way).

 

Hello, thanks for your message, emm, as I said before that I highly depend on IPV6 connection, but the firewall is keeping me out, so I uninstalled it, could you please wait a few minutes as I reinstall it and extract the log file? thanks for your help!


Good afternoon,

thank you for your report, could you please switch on the detailed logging of Firewall in Settings (Settings -> Main -> Advanced -> Report: Change; and also if you will need to reboot to reproduce the problem, could you please check the "Continue detailed logging after reboot" checkbox)? Save your changes, reproduce the problem (switch On firewall, and and switch you network connection off\on  if necessary). You can find the .pcap log file in the root of your system drive. Please send this log to me. 

 

Also could you please answer the following question:

1)  In Firewall -> Settings -> Interfaces choose the "Allow all" rule for your Network interface, save the changes. Will it solve the problem? 

Hello, thanks for your message, emm, as I said before that I highly depend on IPV6 connection, but the firewall is keeping me out, so I uninstalled it, could you please wait a few minutes as I reinstall it and extract the log file? thanks for your help!



#5 Diana Lebedeva

Diana Lebedeva

    ССЗБ

  • Dr.Web Staff
  • 1 054 Сообщений:

Отправлено 21 Март 2014 - 15:23

Yes, sure. 

As I've already told you, please check whether the problem still exists in Allow-all mode for your internet adaptor (In Firewall -> Settings -> Interfaces) and also whether it exists if you restore the default settings for Dr.Web (Settings -> Main -> Restore defaults, but please note that all your custom settings if there were any will be destroyed). 

 

I've tried to reproduce your problem but had no troubles with IPv6 connection. 


Сообщение было изменено Diana Lebedeva: 21 Март 2014 - 15:34

— Чарли, нам нужно поговорить. Есть проблема.

— Почему ты никогда не говоришь «есть решение»?


#6 copyrighthero

copyrighthero

    Newbie

  • Posters
  • 8 Сообщений:

Отправлено 21 Март 2014 - 16:03

Yes, sure. 

As I've already told you, please check whether the problem still exists in Allow-all mode for your internet adaptor (In Firewall -> Settings -> Interfaces) and also whether it exists if you restore the default settings for Dr.Web (Settings -> Main -> Restore defaults, but please note that all your custom settings if there were any will be destroyed). 

 

I've tried to reproduce your problem but had no troubles with IPv6 connection. 

ooooh!! after I set all the interfaces into allow-all mode and restarted the connection, ipv6 backed to work!! Thanks for your help!!

But would allow-all mode brings down security or something? just curius..

p.s. do you still need the log file?

 

Thanks again!

 

 

No, after I restored default settings and connect again, ipv6 is dead..


Сообщение было изменено copyrighthero: 21 Март 2014 - 16:06


#7 SergM

SergM

    Guru

  • Moderators
  • 9 387 Сообщений:

Отправлено 21 Март 2014 - 16:16

all logs will be need.



#8 copyrighthero

copyrighthero

    Newbie

  • Posters
  • 8 Сообщений:

Отправлено 21 Март 2014 - 16:21

all logs will be need.

OKay, just one simple question, how do I upload?  I am kinda new to this forum...  



#9 copyrighthero

copyrighthero

    Newbie

  • Posters
  • 8 Сообщений:

Отправлено 21 Март 2014 - 16:45

Never mind.. it seems okay to set all the interfaces into allow all.. I'll just do that, thank for you guys help anyway!!



#10 Diana Lebedeva

Diana Lebedeva

    ССЗБ

  • Dr.Web Staff
  • 1 054 Сообщений:

Отправлено 21 Март 2014 - 16:59

Please can you give us the log-file even if you decided to set the allow-all mode. You can upload it anywhere (any file hosting service) and give me the link. Thank you in advance.

If with allow-all mode everything works ok, then there should be the rule (or several rules) you could add to default mode to set up your IPv6 connection avoiding using allow-all for your network interface. 


Сообщение было изменено Diana Lebedeva: 21 Март 2014 - 17:01

— Чарли, нам нужно поговорить. Есть проблема.

— Почему ты никогда не говоришь «есть решение»?


#11 copyrighthero

copyrighthero

    Newbie

  • Posters
  • 8 Сообщений:

Отправлено 22 Март 2014 - 03:47

Please can you give us the log-file even if you decided to set the allow-all mode. You can upload it anywhere (any file hosting service) and give me the link. Thank you in advance.

If with allow-all mode everything works ok, then there should be the rule (or several rules) you could add to default mode to set up your IPv6 connection avoiding using allow-all for your network interface. 

ok, few sec..



#12 copyrighthero

copyrighthero

    Newbie

  • Posters
  • 8 Сообщений:

Отправлено 22 Март 2014 - 04:38

ok,I packed my log file you can download it here: http://qyu36361.chinaw3.com/log.zip  please do hurry since this web space is merely a tryout..


and if you find what's wrong with my dr.web settings, please do let me know!! thanks a lot!!



#13 Diana Lebedeva

Diana Lebedeva

    ССЗБ

  • Dr.Web Staff
  • 1 054 Сообщений:

Отправлено 24 Март 2014 - 09:39

It seems that these logs are made with Allow All rule. Could you please repeat with Default rule?  
Can you also try this:
1) Firewall -> Settings -> Interfaces
2) Choose your Network Adaptor, choose Default rule for it
3) Click "Configure..." button
4) At the next screen choose the  Default Rule, and click Edit
5) To set up new packet rule click "New..." button
6) Set up new rule:
Rule name: icmpv6 type 133 (you may change the name if you want)
Description: ipv6-icmp-type routersol  (you may change the description if you want)
Action: Allow packets
Direction: Any
Logging mode: No logging
Criterion: ICMPv6 (choose ICMPv6 from the dropbox, and click Add!)
 after you have clicked "Add" dutton some more options will appear, so you will need to set up them too: 
Type: Equal , in text area type 133
Code: Any:
0_a628b_53477b34_XL.jpg
 
 
7) Click Ok to save the new rule. 
 
After that you will need to create few more rules for ICMPv6 type 134, 128, 129 (the same way):
 
0_a628a_c2976841_XL.jpg
 
0_a6289_18d0407d_XL.jpg
 
0_a6288_841070ef_XL.jpg
 
8) After you will create all the rules they will be in the packet rules list:
0_a6287_40b66132_XL.jpg
 
9) Click Ok
10) Click Ok at the Packet filter Settings window
11) Make sure that the Default rule mode is chosen for your network adaptor
12) Click Ok to save all your settings
 
Than try if your IPv6 connection will work. 
If it won't please save the Pcap logs again. 
 Thank you.


— Чарли, нам нужно поговорить. Есть проблема.

— Почему ты никогда не говоришь «есть решение»?


#14 copyrighthero

copyrighthero

    Newbie

  • Posters
  • 8 Сообщений:

Отправлено 25 Март 2014 - 02:40

ok!thanks a lot for your help!




Читают тему: 1

0 пользователей, 1 гостей, 0 скрытых