Перейти к содержимому


Фото
- - - - -

Dr. Web Firewall + Virtualbox (win7 Host, Winxo Guest) + Hamachi In Guest Cannot Connect


  • Please log in to reply
1 ответов в теме

#1 lolmegafroi

lolmegafroi

    Newbie

  • Posters
  • Pip
  • 3 Сообщений:

Отправлено 16 August 2011 - 16:08

Hi there,

Hamachi does not connect from inside my VM:

VirtualBox 4.1.2, Host: Win7 x64, Guest: WinXP x86, Bridged Adapter (Intel PRO/1000 MT Desktop)

Host has Dr. Web Security Space with the firewall enable. All network traffic is allowed for the VirtualBox process (virtualbox.exe)

If i disable the Dr Web firewall everything works fine, but the host is unprotected... Does anyone have any idea how to solve that? ;)

Thanks in advance

#2 lolmegafroi

lolmegafroi

    Newbie

  • Posters
  • Pip
  • 3 Сообщений:

Отправлено 16 August 2011 - 16:57

Hi folks,

seems like i solved it on my own somehow... I think in the end it's got something to do with Dr Web Firewall filtering packets that are not addressed to the host's IP but the VirtualBox driver/process tries to grab...

Here's what I've done:

- Changed Network adapter from Intel PRO to AMD PCnet-FAST III (imho this has nothing to do with the problem...)
- Changed Promiscuous Mode from "deny all" to "allow for all VMs"
- in Dr Web Firewall settings you can set packet rules for your connections -> for the corresponding LAN adapter it changed the rule from "Default rule" to "Allow all"

As it works now, I won't play around with the settings any longer... I hope this helps anyone looking for some related issue.

Сообщение было изменено lolmegafroi: 16 August 2011 - 16:59





Читают тему: 0

0 пользователей, 0 гостей, 0 скрытых